$re = '/^((00|\+)[0-9]{2,5}|0)[1-9][0-9]{8,9}$/m';
$str = '0566227662
0566227662
0041566227662
+41566227662';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);