const regex = /((?:\+|00)[17](?: |\-|\.)?|(?:\+|00)[1-9]\d{0,2}(?: |\-|\.)?|(?:\+|00)1\-\d{3}(?: |\-|\.)?)?(0\d|\([0-9]{3}\)|[1-9]{0,3})(?:((?: |\-|\.)[0-9]{2}){4}|((?:[0-9]{2}){4})|((?: |\-|\.)[0-9]{3}(?: |\-|\.)[0-9]{4})|([0-9]{7}))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\+|00)[17](?: |\\-|\\.)?|(?:\\+|00)[1-9]\\d{0,2}(?: |\\-|\\.)?|(?:\\+|00)1\\-\\d{3}(?: |\\-|\\.)?)?(0\\d|\\([0-9]{3}\\)|[1-9]{0,3})(?:((?: |\\-|\\.)[0-9]{2}){4}|((?:[0-9]{2}){4})|((?: |\\-|\\.)[0-9]{3}(?: |\\-|\\.)[0-9]{4})|([0-9]{7}))', 'g')
const str = ` 12345678901
12345678901x1234
345678901x1234
12344678901
12345678901
12345678901
12345678901
+4112345678
+441234567890
1 (234) 567-8901
1 (234) 567-8901 x1234
01 23 45 56 78
335.23.23.23.23
0689912549
+33698912549
+33 6 79 91 25 49
+33-6-79-91-25-49
(555)-555-5555
555-555-5555
+1-238 6 79 91 25 49
+1-555-532-3455
+15555323455
55555555555555555555555555
+7 06 79 91 25 49
935 263223 64 949
067 9 91 254 9
331 23 45 56 78
331.23.45.56.78
331 23 45 56.78
33123455678
2312523125
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}