#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:\+|00)[17](?: |\-|\.)?|(?:\+|00)[1-9]\d{0,2}(?: |\-|\.)?|(?:\+|00)1\-\d{3}(?: |\-|\.)?)?(0\d|\([0-9]{3}\)|[1-9]{0,3})(?:((?: |\-|\.)[0-9]{2}){4}|((?:[0-9]{2}){4})|((?: |\-|\.)[0-9]{3}(?: |\-|\.)[0-9]{4})|([0-9]{7}))"
Local $sString = " 12345678901" & @CRLF & _
" 12345678901x1234" & @CRLF & _
" 345678901x1234" & @CRLF & _
" 12344678901" & @CRLF & _
" 12345678901" & @CRLF & _
" 12345678901" & @CRLF & _
" 12345678901" & @CRLF & _
" +4112345678" & @CRLF & _
" +441234567890" & @CRLF & _
" 1 (234) 567-8901" & @CRLF & _
" 1 (234) 567-8901 x1234" & @CRLF & _
"01 23 45 56 78" & @CRLF & _
"335.23.23.23.23" & @CRLF & _
"0689912549" & @CRLF & _
"+33698912549" & @CRLF & _
"+33 6 79 91 25 49" & @CRLF & _
"+33-6-79-91-25-49" & @CRLF & _
"(555)-555-5555" & @CRLF & _
"555-555-5555" & @CRLF & _
"+1-238 6 79 91 25 49" & @CRLF & _
"+1-555-532-3455" & @CRLF & _
"+15555323455" & @CRLF & _
"55555555555555555555555555" & @CRLF & _
"+7 06 79 91 25 49" & @CRLF & _
"935 263223 64 949" & @CRLF & _
"067 9 91 254 9" & @CRLF & _
"331 23 45 56 78" & @CRLF & _
"331.23.45.56.78" & @CRLF & _
"331 23 45 56.78" & @CRLF & _
"33123455678" & @CRLF & _
"2312523125" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")