re = /database_name.*table.*/m
str = 'database_name.table1
/database_name.table1
database_name.table_1
/folder1/folder2/greetings.csv
/folder1/folder2/greetings_1.csv
/folder1/greetings1.csv
/folder1/greetings1.txt
/folder2/folder3/bills3.csv
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end