#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)database_name.*table.*"
Local $sString = "database_name.table1" & @CRLF & _
"/database_name.table1" & @CRLF & _
"database_name.table_1" & @CRLF & _
"/folder1/folder2/greetings.csv" & @CRLF & _
"/folder1/folder2/greetings_1.csv" & @CRLF & _
"/folder1/greetings1.csv" & @CRLF & _
"/folder1/greetings1.txt" & @CRLF & _
"/folder2/folder3/bills3.csv" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")