const regex = /database_name.*table.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('database_name.*table.*', 'gm')
const str = `database_name.table1
/database_name.table1
database_name.table_1
/folder1/folder2/greetings.csv
/folder1/folder2/greetings_1.csv
/folder1/greetings1.csv
/folder1/greetings1.txt
/folder2/folder3/bills3.csv
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}