$re = '/(\s+(fee|fie|foe)){2,4}?fum$/';
$str = 'fee foe fum fie foe fee fum';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);