package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s+(fee|fie|foe)){2,4}?fum$`)
var str = `fee foe fum fie foe fee fum`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}