const regex = /(\s+(fee|fie|foe)){2,4}?fum$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s+(fee|fie|foe)){2,4}?fum$', '')
const str = `fee foe fum fie foe fee fum`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}