$re = '/([A-Za-z0-9.-]*)( at |@)([A-Za-z0-9.-]*)(\.| dot )([A-Za-z]{2,})/';
$str = 'something@virginia.edu
something at virginia.edu
something at Virginia dot edu ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);