package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Za-z0-9.-]*)( at |@)([A-Za-z0-9.-]*)(\.| dot )([A-Za-z]{2,})`)
var str = `something@virginia.edu
something at virginia.edu
something at Virginia dot edu `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}