import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z0-9.-]*)( at |@)([A-Za-z0-9.-]*)(\\.| dot )([A-Za-z]{2,})";
final String string = "something@virginia.edu\n"
+ "something at virginia.edu\n"
+ "something at Virginia dot edu ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}