const regex = /^(|([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\w\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>)((\s*\,\s*)([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\w\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>))*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(|([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\\w\\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>)((\\s*\\,\\s*)([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\\w\\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>))*)$', '')
const str = `Hello <ABC@ABa.COM>, Hi<a@b.com>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}