using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(|([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\w\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>)((\s*\,\s*)([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\w\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>))*)$";
string input = @"Hello <ABC@ABa.COM>, Hi<a@b.com>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}