package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(|([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\w\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>)((\s*\,\s*)([A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+|([\w\s]+)<[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+>))*)$`)
var str = `Hello <ABC@ABa.COM>, Hi<a@b.com>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}