import Foundation
let pattern = ##"https?:\/\/(www.)?[a-zA-Z]+(\.[a-zA-Z]+)+(\/(\w|[-_%.#?=&+])+)+"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://apne.ws/1nRjKS0
http://bit.ly/9H0CQT
http://twitter.com/BBCTimWillcox
http://www.bbc.co.uk/news/magazine-18529371
http://bbc.in/Mb1PWM
http://bbc.in/PCXSFT
http://nbcnews.to/ReH3pK
http://www.breakingnews.com/topic/75-earthquake-off-alaska-january-2013
http://online.wsj.com/news/articles/SB10001424052702304908304579568590603893
http://on.cnn.com/13DsWkq
http://cnnmon.ie/1GZiy8l
http://reut.rs/1sOV13M
http://on.fb.me/i1i3sT
http://econ.st/fcUlsA
http://on.wsj.com/SIji5s
http://on.wsj.com/1J4Id3r
https://word.office.live.com/wv/WordView.aspx?FBsrc=https%3A%2F%2Fwww.facebook.com%2Fattachments%2Ffile_preview.php%3Fid%3D713981818737203%26time%3D1453372782%26metadata&access_token=1604966176%3AAVKzw1ZzsEjWvtPbeu8TWvHPb3URXSaCRCdnoJsfz5TVnQ&title=2016+Stage+ILE+Simulation+d_un+syste_me+d_armes+sous+Simulink.doc
https://www.facebook.com/groups/522095331140491/?multi_permalinks=1255982751085075&ref=notif¬if_t=group_highlights
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)