import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(www.)?[a-zA-Z]+(\\.[a-zA-Z]+)+(\\/(\\w|[-_%.#?=&+])+)+";
final String string = "http://apne.ws/1nRjKS0\n"
+ "http://bit.ly/9H0CQT\n"
+ "http://twitter.com/BBCTimWillcox\n"
+ "http://www.bbc.co.uk/news/magazine-18529371\n"
+ "http://bbc.in/Mb1PWM\n"
+ "http://bbc.in/PCXSFT\n"
+ "http://nbcnews.to/ReH3pK \n"
+ "http://www.breakingnews.com/topic/75-earthquake-off-alaska-january-2013\n"
+ "http://online.wsj.com/news/articles/SB10001424052702304908304579568590603893\n"
+ "http://on.cnn.com/13DsWkq\n"
+ "http://cnnmon.ie/1GZiy8l \n"
+ "http://reut.rs/1sOV13M\n"
+ "http://on.fb.me/i1i3sT\n"
+ "http://econ.st/fcUlsA\n"
+ "http://on.wsj.com/SIji5s\n"
+ "http://on.wsj.com/1J4Id3r\n"
+ "https://word.office.live.com/wv/WordView.aspx?FBsrc=https%3A%2F%2Fwww.facebook.com%2Fattachments%2Ffile_preview.php%3Fid%3D713981818737203%26time%3D1453372782%26metadata&access_token=1604966176%3AAVKzw1ZzsEjWvtPbeu8TWvHPb3URXSaCRCdnoJsfz5TVnQ&title=2016+Stage+ILE+Simulation+d_un+syste_me+d_armes+sous+Simulink.doc\n"
+ "https://www.facebook.com/groups/522095331140491/?multi_permalinks=1255982751085075&ref=notif¬if_t=group_highlights";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}