# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?:\/\/(www.)?[a-zA-Z]+(\.[a-zA-Z]+)+(\/(\w|[-_%.#?=&+])+)+"
test_str = ("http://apne.ws/1nRjKS0\n"
"http://bit.ly/9H0CQT\n"
"http://twitter.com/BBCTimWillcox\n"
"http://www.bbc.co.uk/news/magazine-18529371\n"
"http://bbc.in/Mb1PWM\n"
"http://bbc.in/PCXSFT\n"
"http://nbcnews.to/ReH3pK \n"
"http://www.breakingnews.com/topic/75-earthquake-off-alaska-january-2013\n"
"http://online.wsj.com/news/articles/SB10001424052702304908304579568590603893\n"
"http://on.cnn.com/13DsWkq\n"
"http://cnnmon.ie/1GZiy8l \n"
"http://reut.rs/1sOV13M\n"
"http://on.fb.me/i1i3sT\n"
"http://econ.st/fcUlsA\n"
"http://on.wsj.com/SIji5s\n"
"http://on.wsj.com/1J4Id3r\n"
"https://word.office.live.com/wv/WordView.aspx?FBsrc=https%3A%2F%2Fwww.facebook.com%2Fattachments%2Ffile_preview.php%3Fid%3D713981818737203%26time%3D1453372782%26metadata&access_token=1604966176%3AAVKzw1ZzsEjWvtPbeu8TWvHPb3URXSaCRCdnoJsfz5TVnQ&title=2016+Stage+ILE+Simulation+d_un+syste_me+d_armes+sous+Simulink.doc\n"
"https://www.facebook.com/groups/522095331140491/?multi_permalinks=1255982751085075&ref=notif¬if_t=group_highlights")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.