re = /^[\-a-z]+$/m
str = 'pink-floyd
INVALID
tiësto-NOPE
deadmaus
deadbeef
0xDEADBEEF
none-of-these-&&&
or-these-???
just-lowercase-and-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end