$re = '/^[\-a-z]+$/m';
$str = 'pink-floyd
INVALID
tiësto-NOPE
deadmaus
deadbeef
0xDEADBEEF
none-of-these-&&&
or-these-???
just-lowercase-and-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);