package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\-a-z]+$`)
var str = `pink-floyd
INVALID
tiësto-NOPE
deadmaus
deadbeef
0xDEADBEEF
none-of-these-&&&
or-these-???
just-lowercase-and-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}