import Foundation
let pattern = #"mongoDb: \(variable, subs, value, data\) \{(?<code>(.|\s)*)}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
mongoDb: (variable, subs, value, data) {
let key = "my" + '-index';
let val = arr[key] || "NOPE";
let parity = (val % 2 == 0) ? "even" : "odd";
function poly (x){
arr.map(i => i*2);
return x^2 + 3*x + Math.PI / 2;
}
},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}