# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"mongoDb: \(variable, subs, value, data\) \{(?<code>(.|\s)*)}"
test_str = ("mongoDb: (variable, subs, value, data) {\n"
" let key = \"my\" + '-index';\n"
" let val = arr[key] || \"NOPE\";\n"
" let parity = (val % 2 == 0) ? \"even\" : \"odd\";\n"
" function poly (x){\n"
" arr.map(i => i*2);\n"
" return x^2 + 3*x + Math.PI / 2;\n"
" }\n"
"},\n\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.