re = /mongoDb: \(variable, subs, value, data\) \{(?<code>(.|\s)*)}/
str = 'mongoDb: (variable, subs, value, data) {
let key = "my" + \'-index\';
let val = arr[key] || "NOPE";
let parity = (val % 2 == 0) ? "even" : "odd";
function poly (x){
arr.map(i => i*2);
return x^2 + 3*x + Math.PI / 2;
}
},
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end