import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([0-1][0-9]|2[0-3]):[0-5][0-9](:[0-5][0-9])?)$";
final String string = "17:30\n"
+ "24:00\n"
+ "19:11:07\n"
+ "00:00\n"
+ "00:00:00\n"
+ "23:59\n"
+ "5:50\n"
+ "29:01:02\n"
+ "01:02:03\n"
+ "00:00:59\n"
+ "00:00:60\n"
+ "60:60:60";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}