#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([0-1][0-9]|2[0-3]):[0-5][0-9](:[0-5][0-9])?)$"
Local $sString = "17:30" & @CRLF & _
"24:00" & @CRLF & _
"19:11:07" & @CRLF & _
"00:00" & @CRLF & _
"00:00:00" & @CRLF & _
"23:59" & @CRLF & _
"5:50" & @CRLF & _
"29:01:02" & @CRLF & _
"01:02:03" & @CRLF & _
"00:00:59" & @CRLF & _
"00:00:60" & @CRLF & _
"60:60:60"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")