using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([0-1][0-9]|2[0-3]):[0-5][0-9](:[0-5][0-9])?)$";
string input = @"17:30
24:00
19:11:07
00:00
00:00:00
23:59
5:50
29:01:02
01:02:03
00:00:59
00:00:60
60:60:60";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}