$re = '/(?><.+?>)*((["\'])(?:|(?:.*?)(?:[^\\\\]|[^\\\\]?(?:\\\\{2})+))\2)?/';
$str = '<abc "sss"><span class="key" id="id1">\'while\'</span>"te\\"s\\\\t2"<"fff">"test3"</A>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);