#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?><.+?>)*((["'])(?:|(?:.*?)(?:[^\\]|[^\\]?(?:\\{2})+))\2)?"
Local $sString = "<abc "sss"><span class="key" id="id1">'while'</span>"te\"s\\t2"<"fff">"test3"</A>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")