using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?><.+?>)*(([""'])(?:|(?:.*?)(?:[^\\]|[^\\]?(?:\\{2})+))\2)?";
string input = @"<abc ""sss""><span class=""key"" id=""id1"">'while'</span>""te\""s\\t2""<""fff"">""test3""</A>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}