re = /(?:^((?:(?:\\\\)|(?:\\\\\?\\UNC\\))(?:(?:[^@\\\/]+(?:\:[^@]+@)[^@\\\/\?]+)|(?:[^\\\/?]+)))\\([^\\\/]+)(?:[\\\/]([^?\:]*))?$)/m
str = '\\\\?\\UNC\\server;user:\\pas/sw\\ord@1.1.1\\share\\d\\r\\r
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end