$re = '/(?:^((?:(?:\\\\\\\\)|(?:\\\\\\\\\?\\\\UNC\\\\))(?:(?:[^@\\\\\/]+(?:\:[^@]+@)[^@\\\\\/\?]+)|(?:[^\\\\\/?]+)))\\\\([^\\\\\/]+)(?:[\\\\\/]([^?\:]*))?$)/m';
$str = '\\\\?\\UNC\\server;user:\\pas/sw\\ord@1.1.1\\share\\d\\r\\r
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);