using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^((?:(?:\\\\)|(?:\\\\\?\\UNC\\))(?:(?:[^@\\\/]+(?:\:[^@]+@)[^@\\\/\?]+)|(?:[^\\\/?]+)))\\([^\\\/]+)(?:[\\\/]([^?\:]*))?$)";
string input = @"\\?\UNC\server;user:\pas/sw\ord@1.1.1\share\d\r\r
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}