const regex = /http(s)?:\/\/media(-test)?\.mein-helix.de[a-zA-Z0-9\/]+\/([\w-+.]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http(s)?:\\\/\\\/media(-test)?\\.mein-helix.de[a-zA-Z0-9\\\/]+\\\/([\\w-+.]*)', 'gm')
const str = `<p>Wir sind ein modernes und dynamisches Unternehmen, das mit starken Produkten am Markt ist. Zur Verstärkung unseres Teams suchen wir ab sofort ein/e Alleskönner/in.</p>
<p><img alt="helix-logo-50_1.png" src="https://media-test.mein-helix.de/files/image/2020/09/DydjLfTTupBvdUmFhD0yazQkUJNbx6SU_helix-logo-50_1.png" /></p>
<p><strong>Ihre Herausforderungen</strong></p>
<p> </p>
<ul>
<li>Sie analysieren und verstehen die gegenwärtigen Aufgaben, die sich aus den internen Strukturen und den Ansprüchen der Kunden ergeben.</li>
</ul>
<p> </p>
<ul>
<li>Sie leiten daraus die idealen Lösungen ab und setzen diese gezielt um.</li>
</ul>
<p><img alt="helix-logo-50_1.png" src="https://media.mein-helix.de/files/image/2020/09/DydjLfTTupBvdUmFhD0yazQkUJNbx6SU_helix-logo-50_1.png" /></p>
<p> </p>
<ul>
<li>Sie verwirklichen die Wünsche und Vorstellungen unserer Kunden in bestmöglicher Weise und sorgen so für eine maximale Kundenzufriedenheit.</li>
</ul>
<p> </p>
<ul>
<li>Sie finden ständig neue Wege, um die Wirksamkeit unserer Maßnahmen nachhaltig zu steigern.</li>
</ul>
<p> </p>
<p>jjj</p>
<p><strong>Ihr Profil</strong></p>
<p> </p>
<ul>
<li>Hohe Komplexität, hohe Ungewissheit und das Fehlen eines vorgegebenen Lösungswegs schrecken sie nicht ab.</li>
</ul>
<p> </p>
<ul>
<li>Sie können sich ohne Fachwissen sehr schnell in neue Problembereiche eindenken und lernen schnell.</li>
</ul>
<p> </p>
<ul>
<li>Sie können viele verschiedene (auch unkonventionelle) Lösungen generieren und sich trotz unvollständiger und unklarer Information für eine davon entscheiden.</li>
</ul>
<p> </p>
<ul>
<li>Sie können sich gut selbst strukturieren.</li>
</ul>
<p><br />
Wenn Sie an einer kreativen Arbeitsatmosphäre in einem fantastischen Team, mitten in Bamberg interessiert sind, bewerben Sie sich noch heute online.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}