import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http(s)?:\\/\\/media(-test)?\\.mein-helix.de[a-zA-Z0-9\\/]+\\/([\\w-+.]*)";
final String string = "<p>Wir sind ein modernes und dynamisches Unternehmen, das mit starken Produkten am Markt ist. Zur Verstärkung unseres Teams suchen wir ab sofort ein/e Alleskönner/in.</p>\n\n"
+ "<p><img alt=\"helix-logo-50_1.png\" src=\"https://media-test.mein-helix.de/files/image/2020/09/DydjLfTTupBvdUmFhD0yazQkUJNbx6SU_helix-logo-50_1.png\" /></p>\n\n"
+ "<p><strong>Ihre Herausforderungen</strong></p>\n\n"
+ "<p> </p>\n\n"
+ "<ul>\n"
+ " <li>Sie analysieren und verstehen die gegenwärtigen Aufgaben, die sich aus den internen Strukturen und den Ansprüchen der Kunden ergeben.</li>\n"
+ "</ul>\n\n"
+ "<p> </p>\n\n"
+ "<ul>\n"
+ " <li>Sie leiten daraus die idealen Lösungen ab und setzen diese gezielt um.</li>\n"
+ "</ul>\n\n"
+ "<p><img alt=\"helix-logo-50_1.png\" src=\"https://media.mein-helix.de/files/image/2020/09/DydjLfTTupBvdUmFhD0yazQkUJNbx6SU_helix-logo-50_1.png\" /></p>\n\n"
+ "<p> </p>\n\n"
+ "<ul>\n"
+ " <li>Sie verwirklichen die Wünsche und Vorstellungen unserer Kunden in bestmöglicher Weise und sorgen so für eine maximale Kundenzufriedenheit.</li>\n"
+ "</ul>\n\n"
+ "<p> </p>\n\n"
+ "<ul>\n"
+ " <li>Sie finden ständig neue Wege, um die Wirksamkeit unserer Maßnahmen nachhaltig zu steigern.</li>\n"
+ "</ul>\n\n"
+ "<p> </p>\n\n"
+ "<p>jjj</p>\n\n"
+ "<p><strong>Ihr Profil</strong></p>\n\n"
+ "<p> </p>\n\n"
+ "<ul>\n"
+ " <li>Hohe Komplexität, hohe Ungewissheit und das Fehlen eines vorgegebenen Lösungswegs schrecken sie nicht ab.</li>\n"
+ "</ul>\n\n"
+ "<p> </p>\n\n"
+ "<ul>\n"
+ " <li>Sie können sich ohne Fachwissen sehr schnell in neue Problembereiche eindenken und lernen schnell.</li>\n"
+ "</ul>\n\n"
+ "<p> </p>\n\n"
+ "<ul>\n"
+ " <li>Sie können viele verschiedene (auch unkonventionelle) Lösungen generieren und sich trotz unvollständiger und unklarer Information für eine davon entscheiden.</li>\n"
+ "</ul>\n\n"
+ "<p> </p>\n\n"
+ "<ul>\n"
+ " <li>Sie können sich gut selbst strukturieren.</li>\n"
+ "</ul>\n\n"
+ "<p><br />\n"
+ "Wenn Sie an einer kreativen Arbeitsatmosphäre in einem fantastischen Team, mitten in Bamberg interessiert sind, bewerben Sie sich noch heute online.</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}