#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http(s)?:\/\/media(-test)?\.mein-helix.de[a-zA-Z0-9\/]+\/([\w-+.]*)"
Local $sString = "<p>Wir sind ein modernes und dynamisches Unternehmen, das mit starken Produkten am Markt ist. Zur Verstärkung unseres Teams suchen wir ab sofort ein/e Alleskönner/in.</p>" & @CRLF & _
"" & @CRLF & _
"<p><img alt="helix-logo-50_1.png" src="https://media-test.mein-helix.de/files/image/2020/09/DydjLfTTupBvdUmFhD0yazQkUJNbx6SU_helix-logo-50_1.png" /></p>" & @CRLF & _
"" & @CRLF & _
"<p><strong>Ihre Herausforderungen</strong></p>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Sie analysieren und verstehen die gegenwärtigen Aufgaben, die sich aus den internen Strukturen und den Ansprüchen der Kunden ergeben.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Sie leiten daraus die idealen Lösungen ab und setzen diese gezielt um.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p><img alt="helix-logo-50_1.png" src="https://media.mein-helix.de/files/image/2020/09/DydjLfTTupBvdUmFhD0yazQkUJNbx6SU_helix-logo-50_1.png" /></p>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Sie verwirklichen die Wünsche und Vorstellungen unserer Kunden in bestmöglicher Weise und sorgen so für eine maximale Kundenzufriedenheit.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Sie finden ständig neue Wege, um die Wirksamkeit unserer Maßnahmen nachhaltig zu steigern.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<p>jjj</p>" & @CRLF & _
"" & @CRLF & _
"<p><strong>Ihr Profil</strong></p>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Hohe Komplexität, hohe Ungewissheit und das Fehlen eines vorgegebenen Lösungswegs schrecken sie nicht ab.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Sie können sich ohne Fachwissen sehr schnell in neue Problembereiche eindenken und lernen schnell.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Sie können viele verschiedene (auch unkonventionelle) Lösungen generieren und sich trotz unvollständiger und unklarer Information für eine davon entscheiden.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p> </p>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Sie können sich gut selbst strukturieren.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<p><br />" & @CRLF & _
"Wenn Sie an einer kreativen Arbeitsatmosphäre in einem fantastischen Team, mitten in Bamberg interessiert sind, bewerben Sie sich noch heute online.</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")