re = /(?<=(?:^|[^\\])(?:\\\\)*)(([`'"])(.*?(?:[^\\](\\\\)*|$)(\2|$)))/
str = '"I do not know; but, whatever it is, it will be sunk before night. In any case, it is better to perish with it, than be made accomplices in a retaliation the justice of which we cannot judge."\\n"That is my opinion too," said Ned Land, coolly. "Let us wait for night."'
subst = '<span>$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result