using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:^|[^\\])(?:\\\\)*)(([`'""])(.*?(?:[^\\](\\\\)*|$)(\2|$)))";
string substitution = @"<span>$1</span>";
string input = @"""I do not know; but, whatever it is, it will be sunk before night. In any case, it is better to perish with it, than be made accomplices in a retaliation the justice of which we cannot judge.""\n""That is my opinion too,"" said Ned Land, coolly. ""Let us wait for night.""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}