import Foundation
let pattern = #"((\.) ([A-Z]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Mój nowy adres e-mail to nazwa@domena.pl. A mój nowy numer telefonu to 509-055-002! Coś się wydarzyło 1.10.2019 r. Spalił się bukszpan, który rósł na parapecie. Nauczycielka otworzyła dziennik i powiedziała do Antka: „scharakteryzuj mi budowę mitohondrium”. Dostał „jedynkę”. Pani pokazała nam jak postępować, aby rośliny miały piękne, rozłożyste liście. Coś tam... Pytanie jakieś??? Krzyczenie jakieś!!! Zakończenie skrótem r.? Zakończenie skrótem r. coś? Zakończenie skrótem prof. Adam? Zakńczenie inne...?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)