#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\.) ([A-Z]))"
Local $sString = "Mój nowy adres e-mail to nazwa@domena.pl. A mój nowy numer telefonu to 509-055-002! Coś się wydarzyło 1.10.2019 r. Spalił się bukszpan, który rósł na parapecie. Nauczycielka otworzyła dziennik i powiedziała do Antka: „scharakteryzuj mi budowę mitohondrium”. Dostał „jedynkę”. Pani pokazała nam jak postępować, aby rośliny miały piękne, rozłożyste liście. Coś tam... Pytanie jakieś??? Krzyczenie jakieś!!! Zakończenie skrótem r.? Zakończenie skrótem r. coś? Zakończenie skrótem prof. Adam? Zakńczenie inne...?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")