// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((\.) ([A-Z]))").unwrap();
let string = "Mój nowy adres e-mail to nazwa@domena.pl. A mój nowy numer telefonu to 509-055-002! Coś się wydarzyło 1.10.2019 r. Spalił się bukszpan, który rósł na parapecie. Nauczycielka otworzyła dziennik i powiedziała do Antka: „scharakteryzuj mi budowę mitohondrium”. Dostał „jedynkę”. Pani pokazała nam jak postępować, aby rośliny miały piękne, rozłożyste liście. Coś tam... Pytanie jakieś??? Krzyczenie jakieś!!! Zakończenie skrótem r.? Zakończenie skrótem r. coś? Zakończenie skrótem prof. Adam? Zakńczenie inne...?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}