re = /"([^"\\]*(?:\\.[^"\\]*)*)"|\w+|'([^'\\]*(?:\\.[^'\\]*)*)'/
str = '"The Doors" "Peace Frog" "Down The Road" Bootleg "lol noth\\"ing here" something rofl lol "wtf is going on" \'nope noe noe\' "\'\'\'" "something\'s fishy here..." \'are we "sure that this will work?"\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end