const regex = /"([^"\\]*(?:\\.[^"\\]*)*)"|\w+|'([^'\\]*(?:\\.[^'\\]*)*)'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)"|\\w+|\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\'', 'g')
const str = `"The Doors" "Peace Frog" "Down The Road" Bootleg "lol noth\\"ing here" something rofl lol "wtf is going on" 'nope noe noe' "'''" "something's fishy here..." 'are we "sure that this will work?"'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}