using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^""\\]*(?:\\.[^""\\]*)*)""|\w+|'([^'\\]*(?:\\.[^'\\]*)*)'";
string input = @"""The Doors"" ""Peace Frog"" ""Down The Road"" Bootleg ""lol noth\""ing here"" something rofl lol ""wtf is going on"" 'nope noe noe' ""'''"" ""something's fishy here..."" 'are we ""sure that this will work?""'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}