import Foundation
let pattern = #"(?=\{((?:[^{}]++|\{(?1)\})++)\})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hello hello - helleo
ba blab blab alb
{
"collection1": [
{
"property1": {
"text": "O.P.\nA few forum post ads.\nThanks.",
"href": "bla"
},
"property2": "posted 2010-Jul-26, 1:21 am"
},
]
}
hello2 hello2 - helleo2
ba blab blab alb
{
"collection2": [
{
"property1": {
"text": "O.P.\nA few forum post ads2.\nThanks.",
"href": "bla"
},
"property2": "posted 2010-Jul-26, 1:22 am"
},
]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}