$re = '/(?=\{((?:[^{}]++|\{(?1)\})++)\})/';
$str = 'hello hello - helleo
ba blab blab alb
{
"collection1": [
{
"property1": {
"text": "O.P.\\nA few forum post ads.\\nThanks.",
"href": "bla"
},
"property2": "posted 2010-Jul-26, 1:21 am"
},
]
}
hello2 hello2 - helleo2
ba blab blab alb
{
"collection2": [
{
"property1": {
"text": "O.P.\\nA few forum post ads2.\\nThanks.",
"href": "bla"
},
"property2": "posted 2010-Jul-26, 1:22 am"
},
]
}
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);