use strict;
my $str = 'hello hello - helleo
ba blab blab alb
{
"collection1": [
{
"property1": {
"text": "O.P.\\nA few forum post ads.\\nThanks.",
"href": "bla"
},
"property2": "posted 2010-Jul-26, 1:21 am"
},
]
}
hello2 hello2 - helleo2
ba blab blab alb
{
"collection2": [
{
"property1": {
"text": "O.P.\\nA few forum post ads2.\\nThanks.",
"href": "bla"
},
"property2": "posted 2010-Jul-26, 1:22 am"
},
]
}
';
my $regex = qr/(?=\{((?:[^{}]++|\{(?1)\})++)\})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}