import Foundation
let pattern = #"jest.mock\(\s*\"(?:\.\./){4}src/components/(?P<name>\S+)\",\s*\(\) => \"(?P=name)\"\s*\);"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// BEEP BOOP! I am a generated file. Don't edit me manually.
// @flow
import initStoryshots from "@storybook/addon-storyshots";
jest.mock(
"../../../../src/components/BorderlessButton",
() => "BorderlessButton"
);
jest.mock("../../../../src/components/BorderlessButton", () => "BorderlessButton");
initStoryshots({
storyKindRegex: /^IconButton$/
});
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)