package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`jest.mock\(\s*\"(?:\.\./){4}src/components/(?P<name>\S+)\",\s*\(\) => \"(?P=name)\"\s*\);`)
var str = `// BEEP BOOP! I am a generated file. Don't edit me manually.
// @flow
import initStoryshots from "@storybook/addon-storyshots";
jest.mock(
"../../../../src/components/BorderlessButton",
() => "BorderlessButton"
);
jest.mock("../../../../src/components/BorderlessButton", () => "BorderlessButton");
initStoryshots({
storyKindRegex: /^IconButton$/
});
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}