// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"jest.mock\(\s*\"(?:\.\./){4}src/components/(?P<name>\S+)\",\s*\(\) => \"(?P=name)\"\s*\);"#).unwrap();
let string = "// BEEP BOOP! I am a generated file. Don't edit me manually.
// @flow
import initStoryshots from \"@storybook/addon-storyshots\";
jest.mock(
\"../../../../src/components/BorderlessButton\",
() => \"BorderlessButton\"
);
jest.mock(\"../../../../src/components/BorderlessButton\", () => \"BorderlessButton\");
initStoryshots({
storyKindRegex: /^IconButton$/
});
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}